だいぶ以前に作ったやつなんですが、いちおう公開している以上はメンテしとかないとアレかなと思っているのでメンテしてます。docker-compose 3対応とか、Redmine4の対応とかを行いました。

ベースのイメージに公式のRubyイメージを利用しています。Rubyのバージョンも上げようかと思ったのですが、上げたらalpineのバージョンの関係でImageMagicのインストールがズッコケるので、もうあきらめてRubyのバージョンもalpineのバージョンも上げないことにしました。時間かけたら対応できそうですが、dockerがビルドできない場合の調査と対応ってめんどくさいんですよね。今は以前より簡単になっているんでしょうか?

その他、一つ前の記事のGitBucketもそうなのですが、CircleCIを1.0のまま放置しているので2系にバージョンアップしたいと思いつつも手がついてないです。