24日からビルド時に行っているgem install bundlerがタイトルのエラーが出て落ちていました。

こんな感じ。

1
2
3
+ /var/user/.rbenv/shims/gem install bundler
ERROR: Error installing bundler:
"bundle" from bundler conflicts with /var/user/.rbenv/versions/2.4.1/bin/bundle

GitHubのIssueを見ればわかるのですが、どうも2.6から2.7の間に変更が入ったようです。プロダクトオーナーさんの返答によると、この変更は仕様の用で--forceオプションを試せるのであれば試してほしいとのことです。

ですので、下記のコマンドでインストールします。また、今までは--no-documentをつけていなかったのでついでにコレも付けました。

1
gem install bundler --no-document --force

後は問題なく動きました。上記のIssueに紐づいている他のリポジトリのコミットを見ても同様の対応を行っているので、特別な理由がない限りはこの方法でいいのではないかと思います。